Outage - Investigating
Incident Report for Beam Internet
Resolved
Hi,
Technicians have completed the required work and all services have been restored.

Regards,

Beam Internet
Posted Nov 21, 2019 - 08:28 ACDT
Investigating
Hi, We're currently investigating a network outage affecting customers on western Kangaroo Island. We believe this issue is due to a breaker tripping and a technician is on the way to the tower site. We will post updates as they become available.

Regards,

Beam Internet
Posted Nov 20, 2019 - 20:18 ACDT
This incident affected: Area - Kangaroo Island.