Kangaroo Island - Outage - South East Parndana
Incident Report for Beam Internet
Resolved
This incident has been resolved.
Posted Feb 05, 2020 - 19:32 ACDT
Investigating
We are currently investigating an issue affecting South East of Parndana. Gregor's Rd, East West 1, Rowland Hill Hwy, South Coast rd. we are attending site to investigate further after lightning activity
Posted Feb 01, 2020 - 10:47 ACDT
This incident affected: Area - Kangaroo Island.