Service Interruptions due to Weather Lyndoch Area
Incident Report for Beam Internet
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 18:10 ACDT
Update
We are continuing to investigate this issue.
Posted Feb 07, 2020 - 09:54 ACDT
Investigating
We are currently responding to power alert at our Lyndoch site.
Posted Feb 07, 2020 - 09:51 ACDT
This incident affected: Area - Southern Barossa.