Fire Damage, Kangaroo Island
Incident Report for Beam Internet
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 18:11 ACDT
Investigating
Attention KI Customers. Unfortunately throughout the night some of our infrastructure sustained fire damage. At this stage we are awaiting to gain access to assess the damage and have no firm timeframe for restoration as yet. This will be affecting corporate and residential services on the western end of the island.
Posted Jan 10, 2020 - 09:05 ACDT
This incident affected: Area - Kangaroo Island and Corporate Data/Datacentre Services.