Mail Server Outage
Incident Report for Beam Internet
Resolved
This incident has been resolved.
Posted May 22, 2020 - 08:41 ACST
Monitoring
Reair work has been completed and we will continue to monitor.
Posted May 21, 2020 - 17:33 ACST
Identified
We have identified an issue effecting this server and work to repair is currently underway.
Posted May 21, 2020 - 11:57 ACST
This incident affected: Mail Server - mail.beaminternet.com.au.