Outage - Investigating Kangaroo Island
Incident Report for Beam Internet
Resolved
We have attended the Kingscote tower site and found a faulty breaker. We have replaced the breaker and services have been restored.

If you are still experiencing issues, please call us on 1300 591 261
Posted Jul 31, 2020 - 13:52 ACST
Investigating
Hi, We're currently investigating a network outage affecting Some parts of Kangaroo Island. We will post updates as they become available.

Regards,

Beam Internet
Posted Jul 31, 2020 - 13:34 ACST
This incident affected: Area - Kangaroo Island.