Outage affecting some customers on KI
Incident Report for Beam Internet
Resolved
The issue has been resolved, all services back online.
Posted Jul 08, 2020 - 09:23 ACST
Identified
Engineers have identified the fault and are currently rectifying the issue. We expect services to be re-connected shortly.
Posted Jul 08, 2020 - 08:39 ACST
This incident affected: Area - Kangaroo Island.